F150 Ecoboost Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Just wondering if anyone else has had this problem? While using cruise control at lower rpms it revs up about 200-300 rpm randomly. I think I might have a bad waste-gate, could that cause it to "over boost" causing the problem I'm having while using cruise control?


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,107 Posts
That's probably the torque converter unlocking. Nothing to worry about. Does this happen on slight inclines or going up hill usually?
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
That's probably the torque converter unlocking. Nothing to worry about. Does this happen on slight inclines or going up hill usually?
Actually it only does it when there is no incline, and it stops when the engine is under load or high boost which led me to think it was over boosting


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Really late reply but... did you ever solve this problem? I have a 2012 Platinum with 105k miles and am experiencing the same "surge" in rpm when using cruise control. I'm also experiencing an occasional "shutter" at various rpms (mostly below 2k) and it's really noticeable when towing and going up hills. At times it's enough to shake the entire truck to the point it feels like I'm driving on a washboard road or over those "wake up" grooves on the edge of the road. The truck has never thrown a code when this happens either. I'm up-to-date on service bulletins, replaced spark plugs and ignition coils, new throttle body, drilled weep hole, and cleaned MAP sensors within the last 10K miles. These nuisance issues are really annoying.
 
1 - 6 of 6 Posts
Top