F150 Ecoboost Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
My Service advancetrac warning light keeps coming on intermittently, stays on for awhile then goes goes away. When its on there is no difference in power or steering or anything else, except its annoying the turn signals wont stay on without holding them...anyone else experience this. I drive a 2011.
 

·
Registered
Joined
·
470 Posts
pull any codes?
 

·
Registered
Joined
·
562 Posts
nothing..no codes
The big fuse right off the positive battery terminal. Change it. If you look at it, you'll see the issue. This is a dealer item.
 

·
Registered
Joined
·
562 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #6
sorry, should of done a search, its been covered, however I think the problems for me is the steering angle sensor,(after some research) the fuses on the battery are fine, does it mostly when I am backing into a parking space, the warning light goes going back off when I drive forward for a little.
 

·
Registered
Joined
·
562 Posts
Well, all your symptoms are the same as mine, except I would lose power steering here and there. Not always. Dunno man.
 

·
Registered
Joined
·
2 Posts
My Service advancetrac warning light keeps coming on intermittently, stays on for awhile then goes goes away. When its on there is no difference in power or steering or anything else, except its annoying the turn signals wont stay on without holding them...anyone else experience this. I drive a 2011.

I also was plagued with the crappy "Service Advance Track" and "Power Steering Assist Fail" error alarms like so many others (a common fault on electric power steering racks it seems - look at the 729 F150 complaints rearding this on the afrc dot org site). I only have 23,000 on the truck. It all started soon after I bought the trailer two years ago, and progressively got to the point where it faulted every time I started (not just backing up and turning hard). I just had a shop here replace it with a new (don't get a rebuilt unit - you won't fix the problem since the electronics are not replaced!) for $2100. I also had them replace the front "struts" with Monroe units (complete coil/shocks, $134 each at Amazon, double that at O'Reillys) and the rears with Bilstein 5100s.

The steering fault is from the electronics in the electrical power steering (EPAS) sensors (steering angle, steering torque - the round unit on the rack where the steering column attaches) going bad. With an upgrade OBDI unit (I use FORScan Windows software and a Veepeak scan tool) you can see error messages from the PSCM about erratic signals plus Signal Compare Failure from the Steering Angle Sensor (C1B00) in addition to ABS module messages about "Invalid Data Received From Steering Angle Sensor Module" (U0428) and "Stability Control Inhibit Warning" (C1963). A new rack (EL3Z-3504-AE) seems to have fixed this, and steering has a very different feel from the original rack (CL3Z-3504-AE)
 

·
Premium Member
Joined
·
4,846 Posts
I also was plagued with the crappy "Service Advance Track" and "Power Steering Assist Fail" error alarms like so many others (a common fault on electric power steering racks it seems - look at the 729 F150 complaints rearding this on the afrc dot org site). I only have 23,000 on the truck. It all started soon after I bought the trailer two years ago, and progressively got to the point where it faulted every time I started (not just backing up and turning hard). I just had a shop here replace it with a new (don't get a rebuilt unit - you won't fix the problem since the electronics are not replaced!) for $2100. I also had them replace the front "struts" with Monroe units (complete coil/shocks, $134 each at Amazon, double that at O'Reillys) and the rears with Bilstein 5100s.

The steering fault is from the electronics in the electrical power steering (EPAS) sensors (steering angle, steering torque - the round unit on the rack where the steering column attaches) going bad. With an upgrade OBDI unit (I use FORScan Windows software and a Veepeak scan tool) you can see error messages from the PSCM about erratic signals plus Signal Compare Failure from the Steering Angle Sensor (C1B00) in addition to ABS module messages about "Invalid Data Received From Steering Angle Sensor Module" (U0428) and "Stability Control Inhibit Warning" (C1963). A new rack (EL3Z-3504-AE) seems to have fixed this, and steering has a very different feel from the original rack (CL3Z-3504-AE)
That steering rack info is news to me. Haven't ever heard anything so "official" regarding a new revised rack.

Thanks for the post

Sent from my SM-N950U using Tapatalk
 
1 - 9 of 9 Posts
Top