F150 Ecoboost Forum banner

541 - 560 of 569 Posts

·
Premium Member
Joined
·
677 Posts
Discussion Starter #541
If you drove it and the trans got to 195 plus for a little bit and now you're right between B and A when it is cold, you're golden. When it gets hot, it expands and would be at the top has mark. Clean up the leak and move on.
Truck was running at operating temp when I checked the fluid. I think it might be a little low so I’ll get it topped off to be safe.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #542
Ended up flipping the passenger side drain tube on the turbo. They had a 90* bend at the turbo which was causing oil to back up. Could be why it smoked so much. Took a video and it smokes way less



Before:




Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #543


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4,756 Posts
Truck was running at operating temp when I checked the fluid. I think it might be a little low so I’ll get it topped off to be safe.


Sent from my iPhone using Tapatalk
Only trans temp matters because at 195 the valve opens allowing flow to air to air cooler in front. Air could be in these lines until the valve opens, if fluid fills that up, it takes fluid from pan. Again between the hash marks on cold in this situation and idling at temp would be the top mark.
 

·
Premium Member
Joined
·
5,664 Posts
Was that video a cold start?
Heck, my oem smokes way more than yours does now. :)

Sent from my SM-N950U using Tapatalk
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #547
Was that video a cold start?
Heck, my oem smokes way more than yours does now. :)

Sent from my SM-N950U using Tapatalk
I think it was a cold start but can’t remember I’ve been driving the truck around so I can put miles on it and do more shake down.

Yea it’s still smoking pretty good but I think the oil just needs to burn off at this point. It goes in waves if it smokes a lot or not.

Noticed driver side turbo smoking a little so that might be adding to it still. Need to swap the hose on the driver side too.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #548
Also why is the hot side flaking already?
Good question. The kit was used so maybe that’s why other than that I couldn’t tell you. There’s been a few things I’ve seen already that make me shake my head


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,489 Posts
You’ll need to give it time to get the oil out of the exhaust, if some made it’s way in. It took a very long time for mine to clear up after I blew the turbo.

I think you’re on the right path, but sorry to see you having to fix sh*t you paid someone else to do right.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #550
You’ll need to give it time to get the oil out of the exhaust, if some made it’s way in. It took a very long time for mine to clear up after I blew the turbo.

I think you’re on the right path, but sorry to see you having to fix sh*t you paid someone else to do right.


Sent from my iPhone using Tapatalk
Thank you sir. I’ll give it time and see if it clears up. I’d rather see the truck up and running in the end and that’s what I have my mind focused on right now


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
3,215 Posts

·
Premium Member
Joined
·
677 Posts
Discussion Starter #552
Did some datalogging today and sent them to @Boostking . Saw 56.37 #/min so it’s making good power with room to grow.

Changed the oil and could smell a little gas I think in the oil. Motor now has 400 miles on it now so next miles stone is 750 miles and another oil change.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
408 Posts
Did some datalogging today and sent them to @Boostking . Saw 56.37 #/min so it’s making good power with room to grow.

Changed the oil and could smell a little gas I think in the oil. Motor now has 400 miles on it now so next miles stone is 750 miles and another oil change.


Sent from my iPhone using Tapatalk
Definitely headed in the right direction!
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #555
Good job sorting items. Let's meet this Summer, I think I can still cover you :p
Pffttt that tremor will walk all over my heavy butt


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #556
New revision put on this morning. Drove it around and seems ok. Can’t really test it out until the roads dry up but she gets squirrely when the power comes on

@Boostking said he turned it up a little more so we’ll see. Been getting a whooshing noise which seems to be the BOV not sealing with hard boost. I think I need a stronger spring or BOV so it won’t leak.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
677 Posts
Discussion Starter #557
Well adjusted the bov today and it seems to really like that a lot. Still seems to be leaking but not bad and that could be caused by this oring I found underneath the bov cap. I have a new one coming tomorrow.




Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,489 Posts
Well adjusted the bov today and it seems to really like that a lot. Still seems to be leaking but not bad and that could be caused by this oring I found underneath the bov cap. I have a new one coming tomorrow.




Sent from my iPhone using Tapatalk
Yeah, that will cause a leak. I have a feeling that you’re gonna see some more airflow after that’s fixed.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
5,664 Posts
That picture is the poster board for my diatribe about these motors.

You know, the one where I go on & on about how complex, and how many pieces to the puzzle, and.......

That little innocuous ring of rubber can thwart the whole orchestra from performing the piece properly. It's crazy.

Sent from my SM-N950U using Tapatalk
 

·
Premium Member
Joined
·
817 Posts
Imagine being the calibrator and sitting there going, "WHY IS IT DOING THIS!" This data doesnt match what I told it to do!!!

Onward and upward!
 
541 - 560 of 569 Posts
Top