F150 Ecoboost Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
706 Posts
Discussion Starter · #1 ·
Mine stopped working. No indicator light or cancel SS function. Been looking for what may be wrong, no codes thrown nothing shows up on my BDX.
I'm not interested in full time SS cancellation but have tried KAM reset, jumping the switch and the plug in SS cancellation harness, none have worked. It will cancel SS when the vehicle is cold or the locker engaged as normal.
Any suggestions? KM
 

·
Registered
2015 Lariat 4WD
Joined
·
141 Posts
It is, so unless it was disconnected under the dash it still should be.
 

·
Premium Member
Joined
·
706 Posts
Discussion Starter · #6 ·
Thanks Srp, but no codes shown in FORScan, just checked. Starting to think I shorted or disconnected something the last time I had the radio front trim off to run some wires. Can find no fuse out, everything else works fine just no button function. KM
 

·
Registered
2015 Lariat 4WD
Joined
·
141 Posts
Interesting. On Tapatalk I cannot see the specs of your truck, but on my 15 it will advise a short circuit situation in most cases. Not sure if it does the same for other years.

Pull the bezel and have a look. It is possible something was pinched, maybe the connector wasn’t fully seated and backed out just enough to lose contact or depending on your geographic location, if it is a high humidity or close to a coast where salt permeates the air...corrosion creating high resistance may have caused a failure at a ground or on the connector itself.

I would suggest checking the connector that goes into your BMS as well.
 

·
Registered
2015 Lariat 4WD
Joined
·
141 Posts
Just realized that you must have a newer model due to the topic being start/stop. So FS should show a short circuit situation. Forgive my lack of foresight
 
1 - 8 of 8 Posts
Top