F150 Ecoboost Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
3,220 Posts
Discussion Starter #1 (Edited)
Down the rabbit hole


Follow the instructions in post number 1, use the usb's that are located in post number 2

DO NOT TRY THE FIRMWARE UPDATE -OPTIONAL 1 ----- you will most likely brick your APIM

The usb 1 puts your sync into format mode and the usb 2 forces sync 3.4 with the latest grace note and the newest nav map that was just released....

If you understand how to do manual sync 3 updates you could exchange 3.4 for the latest 3.3 (not sure why you would want that) as it is the latest stable release 19205

and likely the last sync 3 update any pre 2020 ford with sync 3 will ever officially get...

USE AT YOUR OWN RISK, IF SOMETHING BAD HAPPENS ITS ON YOU.

Ive done this update on all 3 of our Ford sync 3 vehicles and had no issues going from 3.0 strait to 3.4 and 3.3 to 3.4 --

fun fact: I have the official nav update for our newest vehicle and after trying for 5 hours to get it to load and it always failing, I used this and it worked fine on the first try.
 
  • Like
Reactions: Blown F-150

·
Registered
Joined
·
5,433 Posts
I was told by my sync guy 3.4 is on the "Gen 4" sync 3 units and will not work on older units at 3.0 version. You need a newer APIM for it to work.

That being said, he sent me pics and I don't like the layout/button style. There is nothing wrong with 3.0 and it does everything you need, no need to upgrade imo.

EDIT-So last i talked to him, this wasnt open, now it is. According to him, if you have nav, you can update and nonnav you will pretty much brick the apim. Also, this update is apparently stealing from Ford because maps update in US is 200$. It is just a different theme and I think the theme looks worse as I said. Not worth the hassle.
 

·
Premium Member
Joined
·
3,220 Posts
Discussion Starter #3
Not sure I understand what your sync guys is talking about.

It works as described
 

·
Registered
Joined
·
800 Posts
So... I just loaded sync 3.4 and when I restarted the car there is no changes. It said it was updating for about ten minutes then said it was successful and I could remove USB. When I restarted it nothing had changed and it still says v3.3
 

·
Registered
Joined
·
800 Posts
Well. Never mind. My fordpass got a notification saying 3.4 was available. When I went online on my laptop it showed v3.3. I didn't look close enough. Just assumed. Why would I get a notification on my phone when it wasn't available online.
 

·
Premium Member
Joined
·
7,262 Posts
I received notice recently of update available and a $150 charge, if memory serves.

I ignored. But I did login to myford and found a free update from what I apparently was running. A minor revision of a few "builds" increase. Applied it via USB, rather than wifi. Went smoothly.

3.3......21 or something like that

Sent from my SM-N950U using Tapatalk
 
  • Like
Reactions: Boltman760

·
Registered
Joined
·
263 Posts
TX Ripper, can you post the link on the how-to and/or video?
Is the USB 1 the top port and USB 2 the bottom? I'm not familiar with all this but can easily figure it out once I get more clarification.
 
1 - 8 of 8 Posts
Top