F150 Ecoboost Forum banner

41 - 60 of 60 Posts

·
Registered
Joined
·
216 Posts
I see in your signature that you have Lockpick installed. Is that correct? If so, is it plug and play? You may have to disconnect it in order to perform the update, and like skytrash said, remove anything plugged into the OBDII port. This screen should only last for about 10 minutes.

Rebecca
I have the exact same issue as Rob with nothing plugged in, no lockpick etc.....its probably my aftermarket wheels though, since they get blamed for any other problem i've ever had on a vehicle....
 

·
Registered
Joined
·
106 Posts
There hasn't been an update to the MFT system since 08-2013.
Do you know if there will be any updates? Perhaps fixing the GPS showing me driving in the field or neighborhood several blocks off from the highway I'm on?

Makes the turn by turn all but useless.
We do plan on updating MFT as needed. The issue you're experiencing is not directly related to the MFT software, but your dealership will be able to diagnose are correct this for you.

Lockpick isn't it, it's not modifying or pulling power from anything it's a pass through design where everything works factory unless you dig for the settings. Nothing OBD2 and even unhooked the airbags. I guess with the master reset I can get radio and media back, fords update just wasn't meant to be. It's a shame something so easy is so complicated.
I have the exact same issue as Rob with nothing plugged in, no lockpick etc.....its probably my aftermarket wheels though, since they get blamed for any other problem i've ever had on a vehicle....
Tires will not cause SYNC to do this. Which "Installation complete" message are you guys getting stuck at? There should be one followed by a reboot, then the second one. If it's the second one, press MENU and then you will be able to remove the USB.

Rebecca
 

·
Registered
Joined
·
1,502 Posts
Mine gets locked at the first one, doesn't even go to reboot. It stops there, and then locks out radio/media so pretty much bricks the sync screen. Only option to get it back is to shut the truck off and open the door, restart the truck and then do a master reset, then reconnect my phone again to the truck each attempt. Is there an option to see what the current sync software is on the device without running a vehicle health report? (Which by the way also seems to hate me) Is it in one of the pages on screen? I found a details page but no sync version on it.
 

·
Registered
Joined
·
216 Posts
I'm at the exact same spot as Rob1334 except I'm up in northern canada, even went out and bought a new usb drive just in case my old one was somehow not working properly, formatted correctly and still get hung up at the same screen.
 

·
Registered
Joined
·
333 Posts
As with every other operation on my sync (4" screen version) the update was slow, overly complicated, and aggrevating. It took 30 minutes and numerous command variations before i finally got my health report to run (which came back with an immediate service required red flag because my parking brake was on). After that it took another 10 mins to find the install option and 15 mins to get it to accept the usb drive/files. Once she said "install complete" it was at least 15 more minutes before the system was functional. Seems like the the complete notification should be at the end.... You know, when it's done. This is the reason i won't ever buy a microsoft surface, smart watch, or phone.
Sounds like you are having a drastically abnormal amount of bad experiences with the system.

Sent from my iPhone using F150 EcoBoost
 

·
Registered
Joined
·
333 Posts
There hasn't been an update to the MFT system since 08-2013. Do you know if there will be any updates? Perhaps fixing the GPS showing me driving in the field or neighborhood several blocks off from the highway I'm on? Makes the turn by turn all but useless.
if you did a level or added larger tires disconnect the battery for for 2 minutes. This fixed my issue with that. No problems since.

Sent from my iPhone using F150 EcoBoost
 

·
Registered
Joined
·
243 Posts
Discussion Starter #48
just to clarify, my original problem was only related to finding the right menus to begin the installation. once I found the menu, which didn't seem to line up with the instructions, I was able to proceed without any trouble at all. And for the record my truck is completely stock.
 

·
Registered
Joined
·
2 Posts
Just downloaded this and will install it this afternoon in my 2014 XLT with MyFord (4" screen), current its at Gen1 4.3 software support. What exactly is new with this update other than the MAP profile and Bluetooth Metadata support (about time BTW). What was fixed with iOS? I switch off to Android and don't use my iPhone anymore but might go back.

Will this finally bring AppLink support to Canada?
 

·
Registered
Joined
·
2 Posts
Just downloaded this and will install it this afternoon in my 2014 XLT with MyFord (4" screen), current its at Gen1 4.3 software support. What exactly is new with this update other than the MAP profile and Bluetooth Metadata support (about time BTW). What was fixed with iOS? I switch off to Android and don't use my iPhone anymore but might go back.

Will this finally bring AppLink support to Canada?
Also want to ask that anyone that has installed 4.4, what metadata do you get with Android?

Im getting track title and artist, but not album or song runtime. Both from the Play Music and Poweramp apps. At least thats whats displayed on the 4" screen as I have Sync with Myford. Perhaps the one line lcd will show more?

USB source does show full metadata (though you have to hit the more info button) to get it all. Really wish it would default to track title, album and artist on three lines on the screen, or even add a 4th line and show genre. Also wish that there was an option to turn on autoscrolling long titles rather than having to hit more. Displaying album art on the screen is probably a pipe dream.
 

·
Registered
Joined
·
48 Posts
Worst update ever! Wish there was a way to reinstall the previous version. I have a 2012 with the touch screen nav. The Bluetooth is not reverting back after ignition cycle and now repeat is on, on the iphone and can't be turned off when connected to sync. Tried a soft reset on the phone, resynced and performed a master reset on sync.....nothing worked. I feel like this update was a huge step backwards. Has anyone else had these same issues with their touch screen nav system? If so what ios are you running on your iphone?
 

·
Registered
Joined
·
1,502 Posts
I have latest ios on my phone, but I still can't get the update to work, I have tried maybe over a dozen times. The only update that screen is going to get is an alpine touch unit.
 

·
Registered
Joined
·
48 Posts
I have latest ios on my phone, but I still can't get the update to work, I have tried maybe over a dozen times. The only update that screen is going to get is an alpine touch unit.
I'm assuming you have the touch screen with nav?
 

·
Registered
Joined
·
48 Posts
Honestly if it didn't work, don't try it again. I haven't heard of anyone with the touch screen with nav having no issues after the install. The only thing that works for me after the update is I can now receive txt msgs. Line in is still coming up after ignition cycle not bluetooth and now when streaming music with the new version of sync repeat is on and can't be turned off on my phone (only had this issue with the new version). If I could go back to last version I would.
 

·
Registered
Joined
·
1,502 Posts
I can't update it at all, it bricks the unit. Only shutting off and restarting and doing a master reset again gets me back to it performing as it did before. I have wasted close to 4 hours now trying to upgrade, and still no luck.
 

·
Registered
Joined
·
3 Posts
I have a 2014 Limited with the navigation and MFT. I guess I am lucky because I didn't have any issues with the upgrade. Didn't want to sit in the truck waisting fuel so I started it before my drive home from work and it finished about 20 minutes later. Only thing I had to do was pair my android phone again.
 

·
Registered
Joined
·
238 Posts
Hey everyone!

I'm glad to see that those of you who've installed the upgrade are liking it! I just wanted to jump in to clarify a few things, Vehicle Health Report is for owners in the U.S. only. If you're in Canada, you can have your dealership connect their diagnostic tool to your vehicle and report your software level to us. The instructions on the website are geared more for basic SYNC than SYNC with MyFord, but I have reported your feedback to my support. If you're having issues installing the update, please be sure your USB is formatted to FAT32, and perform a master reset prior to the install. If you need those instructions, please let me know and I'll post them (be sure to include which system you have).

Rebecca
Rebecca/Ford,
My buddy purchased a 2014 XTR over a year ago. I'm going to update his Sync (4"/NO Touch screen) for him. Has all these bugs been fixed so I can plug in and download? Seeing this thread is 3 years old, is there a new How-To section with this Sync?
 
41 - 60 of 60 Posts
Top