F150 Ecoboost Forum banner

141 - 160 of 162 Posts

·
Administrator
Joined
·
7,736 Posts
I may do it at some point, this truck rode better stock than my 2013 did so I'm happy with it. The 2013 had FX4 suspension and 20" wheels, the next truck is just "normal" suspension and 18" wheels so that helps quite a bit.
 

·
Registered
Joined
·
152 Posts
I may do it at some point, this truck rode better stock than my 2013 did so I'm happy with it. The 2013 had FX4 suspension and 20" wheels, the next truck is just "normal" suspension and 18" wheels so that helps quite a bit.
C’mon you have to do the fronts! Personally, it would drive insane if I did not have the same on all four corners. Pony up the cash and look back later. Sell one of those softball trophies! Glad you like the feel of the rears.


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
7,736 Posts
How many of you that have installed Bilsteins in the rear have re-torqued the bolts/nuts after driving for a few hundred miles? I didn't use threadlocker since I'm lazy and didn't go to the store and buy any. lol
 

·
Administrator
Joined
·
7,736 Posts
I have not. 2000 miles on hers. Should I?

Sent from my SM-N950U using Tapatalk
Not sure, I heard on one of the install videos that it is a good idea too. but the nuts are lock nuts (from what I remember) so you shouldn't have to.
 

·
Premium Member
Joined
·
2,100 Posts
How many of you that have installed Bilsteins in the rear have re-torqued the bolts/nuts after driving for a few hundred miles? I didn't use threadlocker since I'm lazy and didn't go to the store and buy any. lol
They were my Fox shocks, but yes I did re-check them after about 2000 miles.

They were just as tight as when I installed. I wouldn't lose any sleep over it.
 

·
Administrator
Joined
·
7,736 Posts
So I washed my truck the other day and the hose from the self wash caught the top of my antenna and unraveled the wire around it. I had initially cut 6" off the antenna so it wouldn't hit my garage every time I pulled in. Ended up just unraveling the whole wire and cut it with tin snips at the base and expected radio signal to be diminished...but it didn't get any worse.
 

·
Registered
Joined
·
4,430 Posts

·
Administrator
Joined
·
7,736 Posts
How could it catch the wire if the ball is on top?

Also your imgur links never work for me, not even once. It says zoinks failure

Because I cut my antenna down the day I brought my truck home so it wouldn't scrape on the garage ceiling everytime I pull in or out of the garage...aka, the ball and 8" of my antenna are in the trash.

And not sure why they don't show up, are you on a computer or Tapatalk? It shows up fine for me on my heavily monitored work network.
 

·
Registered
Joined
·
4,430 Posts
Because I cut my antenna down the day I brought my truck home so it wouldn't scrape on the garage ceiling everytime I pull in or out of the garage...aka, the ball and 8" of my antenna are in the trash.

And not sure why they don't show up, are you on a computer or Tapatalk? It shows up fine for me on my heavily monitored work network.
You can pop the ball off with a back of a hammer or something similar and JB weld it on to other end and paint. This is what I did on the truck and all vehicles. It looks real clean.
 

·
Administrator
Joined
·
7,736 Posts
You can pop the ball off with a back of a hammer or something similar and JB weld it on to other end and paint. This is what I did on the truck and all vehicles. It looks real clean.
I plan on wrapping aluminum foil around the top to get better reception like my parents did on the TV antennas we had growing up.



(*sarcasm*)
 

·
Administrator
Joined
·
7,736 Posts
Impressed yet again with the mileage of this truck. Round trip to St. Louis and back this past labor day weekend along with a bit of driving around Downtown. All while driving between 75 and 85 mph on the interstate.

 

·
Registered
Joined
·
5,008 Posts
Impressed yet again with the mileage of this truck. Round trip to St. Louis and back this past labor day weekend along with a bit of driving around Downtown. All while driving between 75 and 85 mph on the interstate.

Ugh fricking Tapatalk.. Wish I could see pictures

Sent from my SM-G965U using Tapatalk
 

·
Administrator
Joined
·
7,736 Posts

·
Premium Member
Joined
·
4,524 Posts
Tapatalk issue....... Typical finger-pointing currently.

Which means NOBODY is working on it. Lol

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
5,008 Posts
Tapatalk issue....... Typical finger-pointing currently.

Which means NOBODY is working on it. Lol

Sent from my SM-N950U using Tapatalk
Yeah it's irritating.
It's funny because when I first started using tap talk I could not stand it, now I can't stand using the regular web page.

Sent from my SM-G965U using Tapatalk
 

·
Premium Member
Joined
·
490 Posts
141 - 160 of 162 Posts
About this Discussion
161 Replies
19 Participants
milesej05
F150 Ecoboost Forum
F150Ecoboost.net is the best Ford F150 Ecoboost Forum with discussions on 2011+ F150 Ecoboost Trucks. Discuss performance mods, towing questions, wheels, tires, lift kits, and much more!
Full Forum Listing
Top