F150 Ecoboost Forum banner

61 - 78 of 78 Posts

·
Registered
Joined
·
380 Posts
Thanks for the offer. My 2016 has only a single control solenoid and I've bought one as swapped it without change. My WG actuators hold pressure throughout the system(mightyvac vacuum pump). Did you seal anything else up? My pressure control system and plumbing seems perfect.

Once I got my aftermarket WGs all sealed up, mine stopped having the issue.

I have a WG solenoid that’s good if either of you want to try it.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,219 Posts
Thanks for the offer. My 2016 has only a single control solenoid and I've bought one as swapped it without change. My WG actuators hold pressure throughout the system(mightyvac vacuum pump). Did you seal anything else up? My pressure control system and plumbing seems perfect.
My WG solenoid and system should be same as yours except for the TurboSmart WG's.

Too bad to hear that your's is still acting goofy. Everything that I've been able to gather is that the WG's hyper cycle when they are trying to achieve desired boost.

I'm still open to putting another set of eyes on it, if you like.
 

·
Registered
Joined
·
380 Posts
Now that it's warmed up (a bit) the noise is again at a minimum, but definitely not gone. I appreciate the offer, just living with it for this summer. Maybe take up the quest again in the fall when things cool and the noise increases. Enjoy the riding season.

My WG solenoid and system should be same as yours except for the TurboSmart WG's.

Too bad to hear that your's is still acting goofy. Everything that I've been able to gather is that the WG's hyper cycle when they are trying to achieve desired boost.

I'm still open to putting another set of eyes on it, if you like.
 

·
Premium Member
Joined
·
2,219 Posts
Now that it's warmed up (a bit) the noise is again at a minimum, but definitely not gone. I appreciate the offer, just living with it for this summer. Maybe take up the quest again in the fall when things cool and the noise increases. Enjoy the riding season.
If it get's worse or you change your mind, just shoot me a pm. Enjoy the summer, it's finally warming up!
 

·
Registered
Joined
·
380 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #66
Is your truck a 2011 - 12. From my research for 2013 and up you cant buy a direct fit part for a WG swap.

Once I got my aftermarket WGs all sealed up, mine stopped having the issue.

I have a WG solenoid that’s good if either of you want to try it.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,219 Posts
Is your truck a 2011 - 12. From my research for 2013 and up you cant buy a direct fit part for a WG swap.
I have a 2014. From Ford, no you can't buy just the WG's. But you can buy replacements from TurboSmart, they bolt right in.

For 2013-14, you would need the IWG-75 with a 5psi spring.
 

·
Premium Member
Joined
·
2,219 Posts
How hard are they to replace? If you take off your wheel well liners they should be right there?
I just get at them from the top-side. It's only loosening off the jam nut and the two nuts that mount the WG to the bracket.

If you were pulling the liners for other reasons, it would for sure be easier from the side.
 

·
Registered
Joined
·
1,290 Posts
I just get at them from the top-side. It's only loosening off the jam nut and the two nuts that mount the WG to the bracket.

If you were pulling the liners for other reasons, it would for sure be easier from the side.
Cool thank you sir! I figured it was pretty easy but then again it doesn't hurt to ask lol
 

·
Registered
Joined
·
380 Posts
Update:
I dropped the pan and checked the torque of the bolts. They all seemed fine. I replaced about 7 quarts of fluid and added the dorman transmission pan with the drain bolt. The noise is still there, so my plan in the last post didn't change anything with the noise. Fresh fluid never hurts though.

https://www.amazon.ca/Dorman-265-854-Transmission-Drain-Plug/dp/B07F73ZLW3/ref=asc_df_B07F73ZLW3/?tag=googleshopc0c-20&linkCode=df0&hvadid=335290663574&hvpos=1o1&hvnetw=g&hvrand=14356202672259100577&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9001313&hvtargid=pla-571072923836&psc=1

Capture.JPG
 

·
Registered
Joined
·
52 Posts
Discussion Starter #72
So still have this issue nagging at me. Before spending the cash on the new parts I was thinking I would reset the preload on the factory wastegates. Did you try that before replacing? If so did you go 2 or 3 turns?
 

·
Registered
Joined
·
52 Posts
Discussion Starter #73
So still have this issue nagging at me. Before spending the cash on the new parts I was thinking I would reset the preload on the factory wastegates. Did you try that before replacing? If so did you go 2 or 3 turns?
I just get at them from the top-side. It's only loosening off the jam nut and the two nuts that mount the WG to the bracket.

If you were pulling the liners for other reasons, it would for sure be easier from the side.
 

·
Premium Member
Joined
·
2,219 Posts
So still have this issue nagging at me. Before spending the cash on the new parts I was thinking I would reset the preload on the factory wastegates. Did you try that before replacing? If so did you go 2 or 3 turns?
3 turns according to my Ford tech buddy

I see that Full race now sells OEM replacement Wastegates, pretty awesome if you ask me.
 

·
Registered
Joined
·
1 Posts
Did resetting the factory preload fix your problem?

I replaced drivers side turbo and this started as well. I did the timing chain and phasers. No change with the noise coming from turbo. Hoping someone has had some luck in finding a fix. Seems like it is talked about a lot but then the conversation just ends with no answer.
 

·
Registered
Joined
·
5 Posts
Has anyone figured out a solution. I have pretty much followed these same steps and very similar results. A few good questions still remain:
1) Does the vacuum operated (Aftermarket) BOV solve the issue?
2) Does changing the pre-load on the factory waste gate solenoid solve it?
3) Does replacing the waste gate solenoids with aftermarket solve it?

Do you have a link to the 2013-2104 F150 Ecoboost aftermarket WG?
 
61 - 78 of 78 Posts
Top