F150 Ecoboost Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Saw in today's Columbus Dispatch where a lawsuit was filed in US Dist. Court by drivers claiming the EB will shake and rapidly lose power when trying to accelerate. Sounds like the "humidity stall" issue. Didn't say what model years the offending vehicles were or if all were trucks. Will want to keep an eye on this as it develops. :confused:
 

·
Registered
Joined
·
860 Posts
Ouch, that won't be good press for the ecoboost line. I haven't had that problem, but I do know there is some chat on here and other forums about it. If there is a problem, Ford needs to address it and not just when it happens.
 

·
Registered
Joined
·
344 Posts
I had it happen to my ecoboost. I have about 12000miles on it.
Bought it in December 2012 and mfg. date was September 2012. Don't get me wrong i love this truck.
 

·
Registered
Joined
·
30 Posts
Had this happen to me the other morning. I was getting ready to pass and when I gave it some pedal from about 40mph it felt like it dropped a cylinder and lost power. I let off the pedal, pulled back in my lane and truck started to run fine. I'll be taking it to the shop for maintenance and will have them look into it.
 

·
Registered
Joined
·
229 Posts
Have had it happen to me a few times but it usually clears up.
 

·
Registered
Joined
·
344 Posts
11fx4 and 2012ecoboost ask your dealer about the intercooler.
Mine ran fine after it happened but it could happen at a real bad time
when you don't need it to.
 

·
Registered
Joined
·
30 Posts
JLewis, Was your dealer able to narrow it down to a bad intercooler and what made them think of that? I was thinking more like a faulty coil pack. I had a 2011 fx2 which dropped a coil pack and the symptoms were about the same. Although when the coil pack went out it felt like I was running on 3 cylinders. Thanks for the heads up and I'll keep you all posted. Where are you located in AL?
 

·
Registered
Joined
·
1,529 Posts
JLewis, Was your dealer able to narrow it down to a bad intercooler and what made them think of that? I was thinking more like a faulty coil pack. I had a 2011 fx2 which dropped a coil pack and the symptoms were about the same. Although when the coil pack went out it felt like I was running on 3 cylinders. Thanks for the heads up and I'll keep you all posted. Where are you located in AL?
Ask your dealer to look up the TSB for your symptoms. Ford will replace the intercooler CAC on pre 2013s as a fix to this problem. It has resolved this issue for most. From what I have heard for those that the TSB fix has not solved it has been a catalytic converter or a coil issue.

Good luck!

SPPD
 

·
Registered
Joined
·
15 Posts
I had the same issue on my 2012 fx4 when I went to pass someone. When I stepped on it and pulled past the truck started to shack and act like all the power was gone. Got it into the shop and turned out it was a bad coil pack. If this is an issue with a lot of people ford should really look into why this is happening. Only had about 15000 miles on mine when it happened. Still love my truck though. One of the best I have ever had.
 

·
Registered
Joined
·
12 Posts
My EB F150 was built in late Feb. 2013 and I have not had this issue yet, but will be pulling my travel trailer very soon. I called my dealer and the service manager told me that it was a very small problem, they have only had 2 come back. But I ran into the assistant service manager yesterday and talked to him about it and he told me that they have had over 20 come back in the past 6 months! Does anyone know this issue was addressed before Feb. 2013 when mine was built?
 

·
Registered
Joined
·
191 Posts
Your 2013 should be good to go. Mine (2013) was built Oct 2012 and it has the updated parts already on it. I have had zero issues and really like my Ecoboost.
 

·
Registered
Joined
·
344 Posts
Here's a copy of my service report image.jpg
hope this helps and I'm in montgomery al
 

·
Registered
Joined
·
1,529 Posts

·
Registered
Joined
·
12 Posts
Just spoke to my dealer. My build date is 2/8/13 and the issue had not yet been addressed by Ford for mine. Have not had anything happen but dealer can't touch until it happens and my on board computer has the proper code for them to fix it. I guess that Ford would rather wait until I have my entire family of 6 in the truck and am either pulling my travel trailer or passing a vehicle and in the left lane for the CAC intercooler to 'burp' .
 

·
Registered
Joined
·
191 Posts
Just spoke to my dealer. My build date is 2/8/13 and the issue had not yet been addressed by Ford for mine. Have not had anything happen but dealer can't touch until it happens and my on board computer has the proper code for them to fix it. I guess that Ford would rather wait until I have my entire family of 6 in the truck and am either pulling my travel trailer or passing a vehicle and in the left lane for the CAC intercooler to 'burp' .
Post a photo of the part number tag on your intercooler, my guess is that you have the updated part.
 

·
Registered
Joined
·
15 Posts
I have a family of 5 and that is exactly what happened to me. On my way home from visiting family 2 hours away it happened. Limped it to one of the local dealer, called ford, and they kept telling us the only thing they could due was tow us to the nearest dealer. Well, already being at a dealer they told us to call our insurance company. They too told us nothing they could really do. After 45 minutes going back and forth with each I said screw it and limped it home another hour away. All this happening late at night made matters even worse. When my local dealer got it in they found that one of the coil packs had went bad. Something so simple. Hope this doesn't end up happening to others because ford won't be more proactive. Don't get me wrong. Still love my truck, but wish ford would step to the plate.
 

·
Registered
Joined
·
191 Posts
I don't have a picture with me but I do have the part number : DL 349L440 AC 820

Any way to tell from that?
Same numbers as my 2013, I have read elsewhere that is the latest and greatest intercooler. It should have a plastic shroud over the top 3rd of the front of it. Some owners have had some minor drivability issues (slight miss) that were fixed by narrowing the sparkplug gap to .030". Hope this helps.
 
1 - 20 of 24 Posts
About this Discussion
23 Replies
14 Participants
Yake Bait
F150 Ecoboost Forum
F150Ecoboost.net is the best Ford F150 Ecoboost Forum with discussions on 2011+ F150 Ecoboost Trucks. Discuss performance mods, towing questions, wheels, tires, lift kits, and much more!
Full Forum Listing
Top