F150 Ecoboost Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys, first post on here.

Have a 2011 Ecoboost, roughly 123,000 miles on her.

Have read a few posts on here and other sites about the UPR catch an system and wanted to hear some more reviews about it working under WOT.

As of now I know that during WOT the motor will get some blow by inter the intake manifold and cause it to shutter. I live in FL so the hot moist climate doesn't help.

After installation of your catch can did you notice under WOT the moisture/ blow by not causing the lagging/ shutter in the engine?

I was also told to clean/ flush the CAC prior to install to help with excess build up that is already there. Anyone go through this process as well. If so whats the best way to flush the CAC or other components?

Thanks.

-Andrew
 

·
Registered
Joined
·
951 Posts
^^^ I also drilled the hole, and never cleaned it. I have a 2012 with 100k on it currently and with the UPR catch can. You need to do both. After doing that, do plugs and boots, reset your ECM with the battery disconnect method. That should fix it. . IMO.


2012 screw 3.5L
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
^^^ I also drilled the hole, and never cleaned it. I have a 2012 with 100k on it currently and with the UPR catch can. You need to do both. After doing that, do plugs and boots, reset your ECM with the battery disconnect method. That should fix it. . IMO.


2012 screw 3.5L
Yea I don't know about drilling the CAC. Don't want it dripping on clients driveways or mine.

Did you happen to notice a non shutter WOT after the catch can and plugs?

Now if I could only get my idle to smooth out better. Some days it is good and some not.

Have done a full fuel line clean and valve clean 3 months ago too.
 

·
Registered
Joined
·
951 Posts
Yea I don't know about drilling the CAC. Don't want it dripping on clients driveways or mine.

Did you happen to notice a non shutter WOT after the catch can and plugs?

Now if I could only get my idle to smooth out better. Some days it is good and some not.

Have done a full fuel line clean and valve clean 3 months ago too.
To be quite frank, I never really had a “shutter”, just a rough idle. Occasionally when I would open the throttle it would hesitate, but noting more than that.

I have never put fuel cleaner in my truck, Just dry gas, to get the moisture out.

As far as drilling the CAC. It will initially be wet with oil and water, after that first clear out, it comes out as more or less as water not to much oil, if any oil comes out, it will stick to the truck as vapors. But unfortunately I think this will fix your situation.

You can try plugs and boots first.

The catch can made a big difference in the black soot that flys out on WOT. Also it got rid of a “tinging” I would hear in the engine.

Make sure to do the computer reset after marking the changes.

Good luck, let us know what you come up with.



2012 screw 3.5L
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Drilled my CAC and got some nice oil/water to come out initially. I think my shutter I mainly from my bad spark plugs at WOT. Got a new set today from stage 3 and going to put them in tomorrow.
 
1 - 6 of 6 Posts
Top