F150 Ecoboost Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
have 2013 with 2100 miles the crappy wiring harness that runs down the drivers side frames is falling off cheap tape coming off anyone else have this problem look like crap
 

·
Registered
Joined
·
523 Posts
I haven't experienced this issue. However I have noticed several locations of many harnesses and wire distribution splits that are covered in tape only. Under the hood up by the fuse box, out back by the hitch wiring harness to name a few. My last truck had grommet covered wires with tap only used between the grommet and weather pack connector. It certainly doesn't exude the perception of quality or durability seeing wires only secured in tape.

Inspecting my driver side frame rail. I see the harness your speaking. While it is in grommet. Its routing and attachment points do appear to be an after thought. I would think the inside upper portion of the frame rail would be ascetically better, but not aware of all the engineering considerations or lack there of involved in the routing. The tape on mine in several spots has obviously lost it's adhesion and is coming loose, on mine it is secured with all the push in clips, which are all secure at the moment. I do notice on the where the floor pan the rockers on the unfinished side, there are large square sections of tape covering large square holes. Tape has pealed up and or coming off in several areas. Curious to the tapes purpose. Hopefully it's not meant to keep road grim and elements out of this void area of the rocker.
 

·
Registered
Joined
·
197 Posts
Yeah the trailer harness plug wiring was exposed, I had to tape it up
 

·
Registered
Joined
·
2,595 Posts
Haven't had any exposed or "hanging wires" on my truck. Maybe a couple clips popped loose.
 

·
Registered
Joined
·
30 Posts
Yup! Mine was hanging low right behind the front drivers wheel where the frame comes down and runs horizontal. I had a wire hanger broke off. Looks like an upside down T that the wire look is taped to. I sourced a new clip off another truck and retaped the look up and zip tied for extra holding power.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #6
yea nice 50k truck ford can pull off putting the harness up in the frame looks like crap guess gonna go though it tape it up and zip tie it
 

·
Registered
Joined
·
83 Posts
Discussion Starter #8
right been driving fords all my life own 4 of them right now my dad worked for ford 35 years takes 5mins do something wrong an 10 to do it right
 

·
Registered
Joined
·
1 Posts
have 2013 with 2100 miles the crappy wiring harness that runs down the drivers side frames is falling off cheap tape coming off anyone else have this problem look like crap
Same issues on 2014 model....took ours through corn stubble and took out the cable from front to back.....it was in the shop for 7 work days to get re wired.....
 
1 - 9 of 9 Posts
Top