F150 Ecoboost Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
wife was driving my truck and she said it had no power and the screen on the dash was orange and a wrench light came on,2014 f150 3.5 completely stock with 59,000 miles,she pulled over turned it off waited a few minutes started it and it was fine.so is this a one time thing or is there something i need to check ,took it to autozone and no codes listed.any help appreciated.
 

·
Administrator
Joined
·
770 Posts
Same thing happened to me recently and had no codes. Did it stutter or hesitate when this happened

Sent from my CLT-L04 using Tapatalk
 

·
Registered
Joined
·
146 Posts
My apologies for skipping over that detail.

It's quite strange then why the code wasn't stored. Unless the 'wrench' light is completely unrelated / not linked to the CEL diagnostics system.
 

·
Administrator
Joined
·
4,077 Posts
wife was driving my truck and she said it had no power and the screen on the dash was orange and a wrench light came on,2014 f150 3.5 completely stock with 59,000 miles,she pulled over turned it off waited a few minutes started it and it was fine.so is this a one time thing or is there something i need to check ,took it to autozone and no codes listed.any help appreciated.
As a quick and basic explanation, the wrench light means that there was a minor "issue" with the truck that caused it to go into limp mode before further damage was done.
Pulling over and turning off the vehicle will allow it to restore itself, though 99% of the time no codes will be stored.

The actual CEL means there is a more pressing problem that needs either immediate repair or in the near future to keep significant damage from occurring.
 

·
Registered
Joined
·
184 Posts
When my 2013 Ecoboost did that same thing a couple of times at 33,000 miles it was a bad Electronic Throttle Body. Ford replaced it and I never had anymore problems with it. I traded it for a new F350 diesel (bought a fifth wheel trailer) at 86,000 miles and it was still in excellent condition.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
51 Posts
Discussion Starter #8
Would it pay to put plugs in it and if I would which ones and what gap are they suppose to be,I’m sure there original
 

·
Registered
Joined
·
3,937 Posts
Would it pay to put plugs in it and if I would which ones and what gap are they suppose to be,I’m sure there original
Your plugs are likely due for replacement, but some of these trucks are plagued by bad throttle bodies. Your symptoms lead me toward throttle body.
 

·
Registered
Joined
·
72 Posts
Just got the wrench yesterday out of the blue backing out of the garage. Code p0705 I believe. Took it to the dealer and was going to drop it off but after letting it sit for a bit, the check engine light went off by it self and it ran fine. Drove it all day without a problem. *I had the transmission recall work done 2 weeks ago. Not sure if this is related.
2011 3.5 88,000
 

·
Registered
Joined
·
497 Posts
Just got the wrench yesterday out of the blue backing out of the garage. Code p0705 I believe. Took it to the dealer and was going to drop it off but after letting it sit for a bit, the check engine light went off by it self and it ran fine. Drove it all day without a problem. *I had the transmission recall work done 2 weeks ago. Not sure if this is related.
2011 3.5 88,000
probably need a new lead frame, extended coverage on those, 10 years or 150k
 

·
Registered
Joined
·
51 Posts
Discussion Starter #13
I never had a check engine light or code come up so it’s probably not related but thanks anyways
 

·
Registered
Joined
·
51 Posts
Discussion Starter #14
just checked ford dealer,200 bucks for a new throttle body,called autozone they have a duralast one for 139.00 lifetime warranty,guess i could replace it everytime i get the wrench light.
 

·
Administrator
Joined
·
770 Posts

·
Registered
Joined
·
497 Posts
just checked ford dealer,200 bucks for a new throttle body,called autozone they have a duralast one for 139.00 lifetime warranty,guess i could replace it everytime i get the wrench light.
how lucky do you feel?
 

·
Registered
Joined
·
51 Posts
Discussion Starter #17
the problem is i dont mind spending more for a ford part but these throttle bodys have been a problem all over from what im reading,so for me to go pay 200 for that might work for a year and i have same problem,i might as well buy autozones and have a lifetime warranty.i take brakes back all the time for the warranty along with struts and so on and they never question anything.
 

·
Registered
Joined
·
231 Posts
Keep in mind that moisture from the CAC will cause the same thing to happen (experienced it twice on my 13 before I drilled the weep hole).
 

·
Registered
Joined
·
51 Posts
Discussion Starter #19
Put plugs in tonight they didn’t look to bad they were gapped around 38 thousands,I guess before I put on a throttle body should I drill this weep hole everyone is talking about and does someone have a picture exactly where to drill,thanks for all the help
 
1 - 20 of 27 Posts
Top